Security protection features

Norton Internet Security includes a suite of security tools that help keep your computer safe from viruses, security threats, unwanted email, and privacy intrusions.

Security protection features include:

Personal Firewall

The Personal Firewall protects your computer from Internet attacks, dangerous Web content, port scans, and other suspicious behavior.

About the Personal Firewall

Intrusion Detection

Intrusion Detection scans each piece of information that enters and exits your computer and automatically blocks any Internet attacks.

About Intrusion Detection

Network Detector

Network Detector lets you customize security settings for different networks. This makes it easy for mobile users who connect to the Internet from the road to stay protected at all times.

Customizing protection for different locations

Web assistant

Web assistant lets you customize security settings for individual Web sites without leaving your browser.

Use Web assistant

Privacy Control

Privacy Control gives you several levels of control over the kind of information that users can send via the Web, email, and instant messenger programs.

Protecting your privacy

Ad Blocking

Ad Blocking speeds up your Web surfing by eliminating banner ads, Flash presentations, pop-up and pop-under ad windows, and other slow-loading or intrusive content.

Blocking Internet advertisements

Alert Assistant

The Alert Assistant helps you understand security issues, suggests how you can resolve problems, and advises you on avoiding future security problems.

Learn more with the Alert Assistant

Norton AntiSpam

Norton AntiSpam helps reduce the amount of unwanted email messages that you receive by intelligently filtering incoming messages and clearly marking potential spam.

Blocking unwanted email messages

Parental Control

Parental Control lets parents choose the Web sites and newsgroups that their children can visit and the types of Internet programs that children can use.

Controlling individuals' Internet use


CPDGlossary.html